This forum is now out of date, for our new forum Click Here
YellowFin Jasper Reporting "Error retrieving results"
Question Asked
Our team recently decided to start using Jaspersoft Studio 5.5.2. We have also recently updated the YellowFin Server side .jar file to match the version that we're currently using. However, we are running into some issues getting the reports to run. We ran a very simple jasperreport off of the sql statement "select id from organization". When I attempted to view this report in YellowFin, it returned an error:

Error retrieving results
An error occurred retrieving the results from the database.
Please check the SQL syntax and try again.

The SQL syntax is accurate, as I was able to see this report in JasperSoft. What steps would you recommend to remedy this?

guest

Fri Jul 18, 2014 7:56 AM

Comment
Hi,

Are you able to provide the jasper report file, and also the jasper .jar file you're using in Yellowfin.
Also which version of Yellowfin are you currently using (including build version).

Thanks,
David

David

Fri Jul 18, 2014 3:19 PM

Comment
Thank you for the prompt response.

We are currently on version 6.1 of YellowFin, but I'm not sure what our version history is. I will update when I find out. (FYI, we have plans to update to a newer version of YellowFin soon)

I have attached the jasper file I have used for importing into YellowFin. Our administrator recently updated the .jar file and the only thing I know is that it's the latest version available through JasperSoft.

If I get more details, I will update throughout the day.
Attachments:
Must be logged in to view attachments

guest

Fri Jul 18, 2014 10:07 PM

Comment
Got some more details from our administrator:

YellowFin Info:
App Version: 6.1
Build: 20140318
Java Version: 1.7.0_55

And the .jar we uploaded was version 5.5.2, same as our version of JasperSoft.

guest

Fri Jul 18, 2014 11:38 PM

Comment
Is there any more information you need from my team, David?

guest

Thu Jul 31, 2014 1:10 AM

Comment
Hi,

Sorry for the delays.

I have installed the same version of iReports and confirmed all my 3 test reports are working fine in YF. I did find some issues when adding to a dashboard , which I don't believe is related to your issue.

Unfortunately we no longer support Yellowfin 6.1, as we only support the latest 3 YF versions, which is currently, 6.2, 6.3 & 7.0. Though by the end of the month, it will be 6.3, 7.0 & 7.1 only.

In order for us to investigate further you will need to use a supported version and let us know if you still have issues.

I tested in 7.0 (June 2014 release) using Jasper 5.5.2.
All of my reports were just basic queries, 2 of which had parameters.

E.g.
Select * from authors
where city = CITY

Select * from authors
where State in STATE


Do you have a test machine you can use to install a support version of YF, then create a data source connection to your DB and import your jxml?

Thanks,
David






David

Tue Aug 5, 2014 10:13 AM

Comment
Hey David,

Thank you for the response.

After looking further into the issue, we were able to get some basic queries answered. The issue seemed to stem from an odd permissions issue with our database. Thank you for your help with this.

In the meantime, we have been testing out 7.0 in-house and plan on upgrading in the future.

guest

Wed Aug 6, 2014 3:05 AM